Niyo Global account not getting loaded with initial 5000 Rs

Hello team,

I created my Niyo Global account today and tried to load Rs. 5000 into the account to get the physical card but the payment fails after hours of processing.
I tried with 3 different UPI IDs. For one of them th amount for debited too but payment failed.
Please let me know what is wrong, this is ridiculous.

Hey @Vaishnavi_D.S! Welcome to Niyo Community!

You should be able to add up to 2000 INR via UPI. In case you are trying to load more than that, we’d recommend you try a bank-to-bank transfer by adding your Niyo SBM as a payee and initiate an IMPS/NEFT transaction. If the issue still persists, you may reach out to our live chat support team through the app by navigating Menu > Support options.


Hi Deepak,

Thank you for your reply. I have been trying payments in three parts itself. 2000, 2000 and 1000. The payment is shown as processing for 3-4 hours, later says could not complete payment.
Please let me know how to go about this.

Hey @Vaishnavi_D.S! There seems to be an issue. Also, let us know if you have tried via QR code from the app or have tried sending directly from a different number via the UPI app. And in the meantime, we recommend you try loading the funds from your bank by adding Niyo SBM as a payee.


Hello Deepak,

Thank you for the reply. I transferred the amount with NEFT and it worked.

Thanks again!

1 Like

@Vaishnavi_D.S you are most welcome! Thanks for confirming! :slightly_smiling_face: