Unable to activate UPI

Hello,

After the activation of the debit card, the next step in the app is to activate UPI. However, I am unable to register for the UPI. After clicking on activate UPI option, an error comes which says “We tried to register for you, but something got in the way”
At the same time, I have received the following SMS from IDFC Bank:

  • You have initiated the process of adding your IDFC FIRST Bank accounts to your BHIM UPI. If not requested by you, please contact IDFC FIRST Bank or register a complaint on our helpline no. 1800 419 4332.

  • Hi Himanshu, your UPI handle .niyo@idfcbank is now ready for use.

I am able to transact in the app via Google Pay but unable to access the account details via Niyo app. I have tried to reinstall the app multiple times and waited for 2 days but it isn’t helping.

Has anyone of you faced a similar issue?

6 Likes

Hey Himanshu! We regret the inconvenience. We’re working towards the fix & will notify you through the app once the fix is deployed. Appreciate your patience! ∞VS

1 Like

Hey Shashank,
Do you have any estimated timeline by which the issue should be fixed?

Hey Himanshu! We do not have a tentative timeline as of now. However, we’re trying our best in resolving it as soon as possible. ∞VS

Hey Shashank,
It has been a while and I am still not able to access the app just because I cannot activate UPI.
I have tried using multiple different phone as well but did not get any luck there. You should actually make this UPI activation as an optional step.
A person cannot access the app at all if the UPI is not activated.

7 Days have been passed and Niyo has not been able to resolve a simple issue.
I have already received the debit card but cannot use the app. I guess you guys are lacking at customer support big time and this too when you don’t have as many customers as few new banks.

I agree. The customer support is really lacking at this time. Even if there are delays with any thing like card delivery or a bug fix then they should at least keep the users informed and updated. Early adopter’s user experience should be good enough that they recommend it to others.

2 Likes

Exactly, there are companies who are working in close coordination with their customers (early adopters) to iron out last minute issues before launching the product to the public but this is not happening here.

My experience with the Niyo Global card so not this bad. So I thought this IDFC account seems like a really good idea, if only they can execute it better.

1 Like

Exactly, I had a great experience with their Global Card. The on boarding process and support everything was top notch and that is the reason I opted for the Savings Account but here the case is totally different. It been more than 12 days and I am not able to access my app at all. I can perform all operations via IDFC Bank app but not from Niyo.

True, Niyo Global Card’s onboarding process was so swift. Here I cannot even use the app until I receive my card and I am not sure if I will be able to successfully register UPI or will be stuck like you.

They took almost 10 days to revert with this explanation:
“Regarding your issue it seems that you have Dual Sim due to which you are facing this issue, we recommend you to kindly remove the another Sim and try to activate the UPI from your registered number once”
This is their explanation when I have already told them that I have tried moving SIM in the main slot, removing the other SIM and even trying the SIM in another phone and all of them are giving same issue.
Let’s see how much time it will take them to get this resolved.

Oh man! It really sucks when the customer support comes back with a standard response and thinks that the customer is a total novice. I also think that the employees of the company could be more active on the community. It will help them take direct feedback and improve the product.

Hey Shashank, I don’t think this is such a big issue which your team is not able to resolve even after 20 days. I have received the debit card, the KYC has been done but I am unable to use the app just because UPI is not getting activated.

I have already sent this and I am posting it here as well:
The things I have tried till now to mitigate this issue.

  1. I have tried reinstalling the app several times and I am using the latest version.
  2. I have tried putting my SIM in slot 1 and removing other SIM to make sure SMS is sent from the registered number only.
  3. I have tried using the SIM in another phone to make sure the issue is not with my phone
    However, I have got the same error in all cases. The SMS is being verified successfully but after that, I am getting error. It seems like there is some issue from your backend or IDFC’s backend due to which the UPI is not getting registered.

Hi Himanshu,

Tried all of these but still the issue persists, got update on twitter that the team is working on the fix and hopefully would be resolved in the next update

Hi,

I am unable to proceed with activating UPI, everytime I am getting ‘Awkward’ error and then nothing happens. Please note that am using single sim in handset and all other bank applications works normally. it would be great help if you can find solution so I can start using the app…

Hey Kishore, I am also facing the same issue and I have explained the things that I have tried till now here: https://community.goniyo.com/t/unable-to-activate-upi/369/14

Maybe you can check it and see if you are able to resolve it.

I have been getting this reply for a while now but the issues has not been resolved yet. Let’s see how much more time it will take to resolve the issue.

1 Like

Same problem with UPI. Able to send/receive money through Google Pay but not able to do it through the app. UPI activation through the app is a necessary step for international transactions. And the support team has been very silent on this.

1 Like