Transaction declined on niyo global

Hi…
Inhad used niyo global at various PoS and the transaction declined messages is showing up.I had enabled the transaction on cards and tried resetting the pin.But still not working.Please assist immediately.

Hey @Gokul_Gopakumar! Welcome to Niyo Community!

Regret the inconvenience! This shouldn’t have happened. We’ll have this further investigated and we’ll help you with it. In the meantime, you may try to transact at any different merchant.

Regards,

1 Like

Hey @Gokul_Gopakumar! The transaction issue has been fixed. Kindly try using your card for any of your transactions at any merchant. For any further help, reach out to us and are happy to assist you.

Regards,

1 Like

Hi @Deepak ,
Plese note that the issue has not been resolved .Today i tried a transaction again with niyo global card and the transaction declined message showed up again.Please rectify this immediately as i am presently overseas and not able to make any transactions.
Regards,

Hi @Gokul_Gopakumar, we are sorry to hear this. As we’ve checked, your account and card seem active. Can you please let us know where you are trying to make the transaction? The merchant details, and transaction amount. Also, it would be great if you can share any relevant screenshot or transaction declined receipt that may help us to investigate better.

Regards,

Hi,
I tried first time in chennai and the second time today at NZ.I haven’t took any screen shot. but will share the receipt if the problem persists.The traction amount was 7 NZD today.
Regards,

1 Like

We are having this checked with the bank. In case you face this issue again, we’d request you to help us with the details.

Regards,

Hey @Gokul_Gopakumar! We believe that you were able to make an online transaction in NZD. You should be able to make transactions at other merchants too. For any further help, reach out to us and we are happy to help you.

Hi @Deepak,
I was able to make online transaction.Will checked with merchants and let you know.
Regards.

1 Like

Hi @ Deepak,
Today i faced issue agin with merchand transaction.I can confirm you that the PoS service os activated inthe app.The receipt is attached for your reference.Please resolve the same.
Regards,

@Gokul_Gopakumar Thanks for sharing the receipt. We had escalated this to our team for further investigation. On receiving an update, we’ll reach out to you.

Regards,

Yes same problem with me

Hey @Kumar1975! Welcome to Niyo Community!

The issue might be due to server downtime or connectivity issues. We kindly request you to retry and check if you are able to proceed. Please make sure that you have enabled the transaction modes and set transaction limits. If the issue still persists, please write to us at global@goniyo.com from your registered email and share the transaction declined slip or error screenshot.

Regards,

Now I am getting jittery looking at the above and fearful this might happen with me when I go to Europe. Please ensure this bug is fixed and people who are facing it please update the statuses as well.

I was making a College fee payment, the transaction got failed and the money was deducted from my Niyo Global SBM Account.
This is something serious, kindly resolve the issue as today is the last date of the fee payment.

I was making a College fee payment, the transaction got failed and the money was deducted from my Niyo Global SBM Account.
This is something serious, kindly resolve the issue as today is the last date of the fee payment.

Hey @HUZAIF! inconvenience regretted! The transaction might have declined due to connectivity issues. If the amount has been debited for a declined transaction, you’ll receive a refund to your account within 2-3 business days. We kindly request you to wait until then. You may share a screenshot of the declined page with us for reference.

Regards,

1 Like

A post was merged into an existing topic: Need loan personal loan

Hello,

I faced same problem with my Niyo global card in madrid. I don’t understand, if this issue persists should I carry cash all the time? How reliable is this card? I know kind of regret taking this card instead of forex cards who have 24/7 customer support. I can’t even talk to a customer executive for Niyo global in emergency. Please resolve this issue and let me know the reason for this issue.

1 Like

Facing the same issue!
Card is having sufficient balance but is declining constantly from past 2 days. Error says declined since POS is locked. Tried resetting transaction settings as well. Still facing same issue. I am in helpless condition right now.
Concerned team, please respond on high priority