Getting transaction declined message on foreign currency transactions


I’m trying to transact in AED but getting ‘Transaction Declined’ message on POS/ATMs. I have sufficient balance on my card.

Can somebody please help?

Hi @Neha_Dol,

I’d recommend going to - card settings>>>> Other locks. Tap on any red icons there to make them green and enable those transactions,

Also goto- card settings>>>> card limits. There you can set card transaction limits (in this case you would want to check card swipe limits).

Hopefully this should help.


1 Like